Delay on systems
Incident Report for ViaBill
Resolved
This incident has been resolved.
Posted Jul 30, 2021 - 09:25 UTC
Investigating
We are currently experience a slowdown of events on our systems. We are investigating the issue.
Posted Jul 30, 2021 - 08:09 UTC
This incident affected: Callback API and 3rd Party (SMS).