Shop overview on Viabill website is not showing shops in the lists.
Incident Report for ViaBill
Resolved
This incident has been resolved.
Posted Aug 18, 2021 - 12:26 UTC
Investigating
We are currently investigating this issue.
Posted Aug 18, 2021 - 11:28 UTC
This incident affected: Website.